解决.NET2.0无法识别的配置节的方法

2012-6-27 13:09:48 来源:网络转载 浏览:274
打开IIS,右键点击站点-->击站点-->属性-->ASP.NET标签中的版本改成2.0.50727就可以了属性-->ASP.NET标签中的版本改成2.0.50727就可以了

asp.net1.1升级到2.0的方法

问题:

配置错误

说明: 在处理向该请求提供服务所需的配置文件时出错。请检查下面的特定错误详细信息并适当地修改配置文件。

分析器错误信息: 无法识别的配置节“connectionStrings”

源错误:

行 1: <configuration>行 2: 行 3: <connectionStrings/>行 4:   ......

源文件: F:\User\site\CS_2.1.60809.935_SDK\source\Web\web.config    行: 3

原因:

用vs2005开发的asp.net应用程序需要使用.net framework 2.0,而在iis中的默认.net环境是1.1。这时将发生不可识别的节点的问题。

解决办法:

将.net环境升级为2.0,开始-》运行-》cmd-》

C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\aspnet_regiis.exe -i

完了之后打开IIS,右键点击站点-->属性-->ASP.NET标签中的版本改成2.0.50727就可以了

(0)
(0)