phpMyAdmin 3.x setup脚本存在远程跨站脚本漏洞

2011-4-25 15:13:36 来源:网络转载 浏览:179
phpMyAdmin 3.x setup脚本存在远程跨站脚本漏洞
影响版本:
phpMyAdmin 3.x

程序介绍:

phpMyAdmin是用PHP编写的工具,用于通过WEB管理MySQL。

漏洞分析:

phpMyAdmin的setup脚本没有正确地过滤提交给setup/frames/index.inc.php页面的参数,远程攻击者可以通过恶意服务器名称注入并执行任意Web脚本或HTML。


漏洞利用:




解决方案:
安全建议:

<*厂商补丁:

phpMyAdmin
----------
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:

http://phpmyadmin.git.sourceforg ... 5702d62f88247ce09dd
*>

信息来源:
<*参考

Tenable Network Security (http://www.tenablesecurity.com/

http://secunia.com/advisories/41210
http://www.phpmyadmin.net/home_page/security/PMASA-2010-7.php

*>

(0)
(0)