ASPJar Guestbook跨站脚本(CSS/XSS)执行漏洞

2011-2-24 10:26:56 来源:网络转载 浏览:185
ASPJar Guestbook跨站脚本(CSS/XSS)执行漏洞
影响版本:
ASPJar Guestbook 1.0

程序介绍:

ASPJar Guestbook是一款简单的留言系统,可使用在多种Linux和Unix操作系统下。

漏洞分析:

ASPJar Guestbook对用户提交到留言版内容中的数据缺少正确充分的检查,可导致远程攻击者进行跨站脚本执行攻击。
当攻击者在留言版中输入信息时,PHPImageView没有过滤脚本代码和HTML标记,可导致攻击者提供包含恶意脚本代码的信息给留言版,当其他用户浏览此包含恶意代码的链接时,可导致代码在浏览用户的浏览器上被执行,使用户基于Cookie认证的信息泄露。
另外,存在漏洞攻击者可以无需验证直接访问“delete”脚本来删除留言条目。

解决方案:
临时解决方法:
如果您不能立刻安装补丁或者升级,建议您采取以下措施以降低威胁:
* 修改程序,严格过滤用户输入的数据,不允许JavaScript脚本或对<>字符进行转换。
* 设置浏览器禁用JavaScript。

厂商补丁:
ASPJar
目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
http://www.aspjar.com/

(0)
(0)